incompatible upgrade of apache traffic server

Jan-Frode Myklebust janfrode at tanso.net
Fri Jun 29 12:49:15 UTC 2012


On Wed, Jun 27, 2012 at 07:11:32PM +0200, Gregor T├Ątzner wrote:
> On Tuesday 26 June 2012 20:56:24 Jan-Frode Myklebust wrote:
> > Will it be OK to do this upgrade in F15/F16/F17, or are we stuck on v3.0 ?
> 
> I'm not a user of this particular apache service, but in general I would vote 
> -1
> There is a reason why those update policies exist: Fedora is no rolling 
> release :)

I know, but I think this is a packaged that is not much used (quite
new), most serious users will likely be reachable from the
traffic-server-users mailinglist, and it's only two options that are not
used by default that changes.


> >   * The update fixes serious bugs that many fedora users are
> >     encountering [Applies, fixes segfault]
> How do you know. Are you getting many bug reports?

I've hit the bug myself, and I know it's also been reported by others in
the ATS issue tracker. 

	https://issues.apache.org/jira/browse/TS-1276

I've not received any bugreports, and have actually never received any
feedback from any users (adding weight to my assumption that there are
very few users).

> 
> If v3.0 is basically broken an upgrade is imho justified, else the cons seems 
> to overweight, especially the manual intervention for adjusting the config 
> files.

v3.0 is still maintained, so the crash bug will likely be fixed.


  -jf


More information about the devel mailing list