Fixing Puppet in Fedora/EPEL

Matthew Miller mattdm at fedoraproject.org
Tue Oct 23 15:21:57 UTC 2012


On Tue, Oct 23, 2012 at 03:47:43PM +0200, Vít Ondruch wrote:
> Yes, I understand that ... therefore you need two versions of puppet
> installed in parallel. There was proposal to prepare puppet3
> package, while I think that the correct way is to move puppet to
> version 3 and prepare new puppet2 or compat-puppet package.

That's probably correct for a new major release. It's not okay during the
lifecycle of a stable product, if we can avoid it. (Sometimes we can't.
We're not at "can't" yet for this.)

> Once you introduce version into the name, you will never be able to
> get rid of it, although puppet 4 might be 100% compatible with

That's not true. In the future, puppet can obsolete puppet3 -- for example,
in EPEL 7.

-- 
Matthew Miller  ☁☁☁  Fedora Cloud Architect  ☁☁☁  <mattdm at fedoraproject.org>


More information about the devel mailing list