Fixing Puppet in Fedora/EPEL

Michael Stahnke stahnma at puppetlabs.com
Tue Oct 23 23:02:33 UTC 2012


On Tue, Oct 23, 2012 at 2:50 PM, Jan-Frode Myklebust <janfrode at tanso.net> wrote:
> On Sat, Oct 20, 2012 at 1:04 AM, Michael Stahnke <stahnma at puppetlabs.com> wrote:
>> Puppet in the Fedora/EPEL ecosystem is a bit wonky currently.
>>
>> I'd really like to fix it.
>>
>> Problems:
>> * Fedora 17 (and higher) ships with Ruby 1.9.x and Puppet 2.7.x.  2.7.x is not
>>   100% compatible with 1.9.3. The number of issues in this space continues to
>>   grow.
>
>> * Puppet 3.0.x is out and is the fully supported branch from Puppet Labs and
>>   supports Ruby 1.9.3+ fully.
>
>>
>> My proposal would be the following:
>> * Move EPEL 6, Fedora >= 17 to use Puppet 3.0.
>
> What about ruby on RHEL6? Will puppet 3.0 work with RHEL6's ruby
> 1.8.7, or do you expect RHEL6 users to replace the distro native ruby
> stack ?
1.8.7 is fully supported in Puppet 3.0
>
>
>
>   -jf
> --
> devel mailing list
> devel at lists.fedoraproject.org
> https://admin.fedoraproject.org/mailman/listinfo/devel


More information about the devel mailing list