A need for build triggers & automatic rebuilds

Nicolas Mailhot nicolas.mailhot at laposte.net
Mon Jun 24 10:49:55 UTC 2013

Le Lun 24 juin 2013 11:59, Aleksandar Kurtakov a écrit :

> This shows another problem though: expressing version range in a spec file
> e.g there is no easy way to say I want a package that provides osgi(smth)
> [1.0.0, 1.5.0). If you try to express it with RPM requires as two
> statements:
> Requires: osgi(smth) >= 1.0.0
> Requires: osgi(smth) < 1.5.0
> it's not exactly the same  as having packages providing osgi(0.9) and
> osgi(1.6.0) will satisfy this requirements too. I know this is
> hypothetical but it shows the inability to require version range in RPM
> terms reliably. And the way to get that but not fail-proof is too verbose
> now.

You can express it reliably :
Requires: osgi(smth) >= 1.0.0
Conflicts: osgi(smth) >= 1.5.0

The drawback being you can not have two generations of osgi(smth)
on-system (but having two generations will confuse lots of apps anyway)

Nicolas Mailhot

More information about the devel mailing list