libgd breakage

Volker Fröhlich volker27 at gmx.at
Wed Jun 26 14:01:19 UTC 2013


On Wed, 2013-06-26 at 09:52 -0300, Paulo César Pereira de Andrade wrote:
> 2013/6/26 Remi Collet <Fedora at famillecollet.com>:
> > Le 26/06/2013 14:36, Paulo César Pereira de Andrade a écrit :
> >>   Hi,
> >>
> >>   It is taking a bit too long for some dependencies to be rebuilt
> >> in rawhide.
> >>
> >>   Could a compat-libgd be provided please? I am receiving daily
> >> mails about broken deps, already posted to $pkg-owner@ asking
> >> what I could help, but still no response neither problems corrected.
> >> Remi Collet told me it appears there are some FTBFS packages in
> >> the cycle.
> >
> > As none of the FBTFS are related to libgd, I don't see any value to have
> > a compat-libgd package.
> 
>   I see this failure in root.log:
> 
> DEBUG util.py:264:  Error: Package: gnuplot-4.6.2-2.fc20.i686 (build)
> DEBUG util.py:264:             Requires: libgd.so.2
> DEBUG util.py:264:  Error: Package: gdal-libs-1.9.2-7.fc20.i686 (build)
> DEBUG util.py:264:             Requires: libpoppler.so.34
> DEBUG util.py:264:  Error: Package:
> 2:texlive-dvipng-bin-svn30088.0-24.20130531_r30819.fc20.i686 (build)
> DEBUG util.py:264:             Requires: libgd.so.2
> DEBUG util.py:264:  Error: Package: gdal-1.9.2-7.fc20.i686 (build)
> DEBUG util.py:264:             Requires: libpoppler.so.34
> DEBUG util.py:264:  Error: Package:
> 2:texlive-pdftex-bin-svn30088.0-24.20130531_r30819.fc20.i686 (build)
> DEBUG util.py:264:             Requires: libpoppler.so.34
> DEBUG util.py:264:  Error: Package:
> 2:texlive-luatex-bin-svn30739.0-24.20130531_r30819.fc20.i686 (build)
> DEBUG util.py:264:             Requires: libpoppler.so.34
> DEBUG util.py:264:   You could try using --skip-broken to work around
> the problem
> 
> s/i686/x86_64/ for the x86_64 build error. This is happening for almost
> two weeks I believe.
> 
>   Sorry for posting to the devel list, but I thought it could be required
> to attract the proper attention.
> 
> > Remi.
> >
> >>
> >>   I would like to also start working on packaging sagemath 5.10,
> >> but am not providing as much time to work on fedora as I would
> >> want, so also not providing a compat-libgd sample package,
> >> sorry...
> 
> Thanks,
> Paulo

GDAL is currently broken because it needs a rebuild for Poppler, but the
Texlive build is broken, as far as I can see.

Volker



More information about the devel mailing list