Soname bump libpng (rawhide) - new libraries libpng.16.so and libpng16.so.16.2.0

Peter Robinson pbrobinson at gmail.com
Wed May 22 08:39:06 UTC 2013


On Fri, May 17, 2013 at 12:17 PM, Kalev Lember <kalevlember at gmail.com> wrote:
> 2013-05-17 12:20, Petr Hracek skrev:
>> Hi folks,
>>
>> in order that BZ (https://bugzilla.redhat.com/show_bug.cgi?id=963113)
>> libpng library was bumped.
>>
> [snip]
>>
>> Please rebuild your packages with new libpng library
>> Here is the list:
> [snip, 306 packages]
>
> Hi Petr,
>
> Very cool to get updated libpng! However please hold your horses with
> the new build. Rushing it in without coordination could break rawhide
> for a week or longer.
>
> The issue is that once this is in, all the 306 packages above will have
> broken dependencies. And it's not just simple rebuilds that are
> required; we'd need _ordered_ rebuilds in dependency order: build deps
> that require the old libpng can't be installed in the koji build roots
> without rebuilding them first. And this means individual package
> maintainers can't fix their packages before someone has fixed things
> down in the dep chain.

The way it was done last time on the 1.5 upgrade was to have a
compat-libpng package that had the 1.5 release so that nothing broke
while things were rebuilt and then once the vast majority of the
rebuild happened it was then dropped to avoid this problem.

Peter


More information about the devel mailing list