Problem getting package to compile on EL6

Orion Poplawski orion at cora.nwra.com
Tue Sep 10 22:05:21 UTC 2013


On 09/10/2013 02:40 PM, Susi Lehtola wrote:
> Hi,
>
>
> I have a very weird problem. I'm trying to update the EPEL
> branches of json-c to 0.11. It builds just fine on EL5, but on EL6 the
> build crashes at
>
> + /usr/lib/rpm/find-debuginfo.sh --strict-build-id /builddir/build/BUILD/json-c-json-c-0.11-20130402
> extracting debug info from /builddir/build/BUILDROOT/json-c-0.11-4.el6.x86_64/usr/lib64/libjson-c.so.2.0.1
> extracting debug info from /builddir/build/BUILDROOT/json-c-0.11-4.el6.x86_64/usr/lib64/libjson.so.0.1.0
> error: Bad exit status from /var/tmp/rpm-tmp.Zd6awY (%install)
>      Bad exit status from /var/tmp/rpm-tmp.Zd6awY (%install)
> RPM build errors:
> Child return code was: 1
> EXCEPTION: Command failed. See logs for output.
>
> Running find-debuginfo.sh manually in the mock chroot, I get
>
> $ /usr/lib/rpm/find-debuginfo.sh --strict-build-id /builddir/build/BUILD/json-c-json-c-0.11-20130402/
> find: cannot search `': No such file or directory
> find: `debug': No such file or directory
>
> What might be the cause of this problem?
>

I can track it down to debugedit segfaulting:

$ /usr/lib/rpm/debugedit -b /builddir/build/BUILD/json-c-json-c-0.11-20130402 
-d /usr/src/debug -i -l 
/builddir/build/BUILD/json-c-json-c-0.11-20130402/debugsources.list 
/builddir/build/BUILDROOT/json-c-0.11-4.el6.x86_64/usr/lib64/libjson.so.0.1.0
Segmentation fault


Perhaps related to: https://bugzilla.redhat.com/show_bug.cgi?id=903009 but I'd 
have to see a stack trace to be sure.

-- 
Orion Poplawski
Technical Manager                     303-415-9701 x222
NWRA, Boulder/CoRA Office             FAX: 303-415-9702
3380 Mitchell Lane                       orion at nwra.com
Boulder, CO 80301                   http://www.nwra.com


More information about the devel mailing list