Packages requiring Xorg "BackingStore" "true"

Sandro Mani manisandro at gmail.com
Thu Sep 12 14:49:17 UTC 2013


On 12.09.2013 16:41, Adam Jackson wrote:
> On Wed, 2013-09-11 at 23:27 +0200, Sandro Mani wrote:
>>> Well, yes, but it ought to work regardless of the xorg.conf setting,
>>> because that setting has been effectively hardwired to true for about
>>> six years now.  I rewrote the backing store implementation to use
>>> Composite internally, which is always available, so we just blindly
>>> ignore the config setting and give you backing store if you ask for it.
>>> There may be bugs, I freely admit, but it's definitely meant to work.
>>> If it doesn't it's probably a bug in X and I'll fix it, so hook me up
>>> with test packages and I'll take a look.
>> I've uploaded an x86_64 rpm here [1], the srpm is here [2]. To reproduce
>> the problem, first download the foil gometry [3], then run xfoil from a
>> terminal, and type
>>
>> load Naca63412.dat
>>
>> and at the following "Enter airfoil name" prompt, type
>>
>> naca63412
>>
>> Upon pressing enter, the Xplot11 window should open, showing the
>> cross-section of the foil.
>>
>> The Xlib code for the plotting window is in plotlib/Xwin.c in the xfoil
>> source tarball.
> Oh my, this is embarassing.  If only I'd deleted more code you'd never
> have hit this.  Definitely a bug in xserver.  I'll send a patch upstream
> and fix Fedora once that lands.  Thanks for the testcase!

Awesome, thanks!



More information about the devel mailing list