Packages requiring Xorg "BackingStore" "true"

Sandro Mani manisandro at gmail.com
Thu Sep 12 19:40:36 UTC 2013


On 12.09.2013 21:30, Przemek Klosowski wrote:
> On 09/11/2013 05:27 PM, Sandro Mani wrote:
>>
>>> Well, yes, but it ought to work regardless of the xorg.conf setting,
>>> because that setting has been effectively hardwired to true for about
>>> six years now.  I rewrote the backing store implementation to use
>>> Composite internally, which is always available, so we just blindly
>>> ignore the config setting and give you backing store if you ask for it.
>>> There may be bugs, I freely admit, but it's definitely meant to work.
>>> If it doesn't it's probably a bug in X and I'll fix it, so hook me up
>>> with test packages and I'll take a look.
>> I've uploaded an x86_64 rpm here [1], the srpm is here [2].
> ...
>> [1] http://smani.fedorapeople.org/xfoil-6.97-1.fc21.x86_64.rpm
>> [2] http://smani.fedorapeople.org/xfoil-6.97-1.fc21.src.rpm
>> [3] http://smani.fedorapeople.org/Naca63412.dat
> I compiled the RPM from your source on F19/x86_64 with an Xeon E3-1200 
> v2/3rd Gen using the intel driver (Ivybridge GT2). As ajax was saying, 
> the window exposes work just fine: I can raise other windows on top of 
> xfoil and when I re-expose xfoil it redraws properly.
>
>
You likely have a compositing window manager running? Cause it 
definitely did not work with kwin with compositing turned off. Anyway, 
ajax has posted patches for this to the xorg-devel list [1]. And btw, 
I've now posted a review request for xfoil [2] with a polished srpm, in 
case you are interested.

Sandro

[1] http://lists.x.org/archives/xorg-devel/2013-September/037773.html
[2] https://bugzilla.redhat.com/show_bug.cgi?id=1007539
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.fedoraproject.org/pipermail/devel/attachments/20130912/83c5a308/attachment.html>


More information about the devel mailing list