Full subpackage (-n type) with different version from main package

Richard Shaw hobbes1069 at gmail.com
Sun Sep 15 17:09:21 UTC 2013

On Sun, Sep 15, 2013 at 12:07 PM, Richard Shaw <hobbes1069 at gmail.com> wrote:

> On Sun, Sep 15, 2013 at 11:58 AM, Dridi Boukelmoune <
> dridi.boukelmoune at gmail.com> wrote:
>> Hi,
>> Have you tried to tweak the %setup macro with the -n option ?
> Yes, I have to because the source name doesn't match the package name
> anymore...
> %setup -q -n %{srcname}-%{version}
> where srcname is defines at "tqsl"
> I could make another version definition but that seems wrong somehow and
> even if that fixes cd'ing into the source dir, I'm not sure it would fix
> the final package names...

Just tried that (%global tqslver 1.14.3) and it worked. Even named the
packages correctly!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.fedoraproject.org/pipermail/devel/attachments/20130915/4842e71e/attachment.html>

More information about the devel mailing list