ibus-typing-booster Obsoletes failure

Michael Schwendt mschwendt at gmail.com
Mon Sep 16 10:13:32 UTC 2013

On Mon, 16 Sep 2013 10:51:41 +0200, Mike FABIAN wrote:

> > What is going on in package "ibus-typing-booster"?
> >
> > http://pkgs.fedoraproject.org/cgit/ibus-typing-booster.git/plain/ibus-typing-booster.spec
> >
> > It attempts at obsoleting various packages, but since it does that with a
> > specific dist tag and without retiring those packages, it fails entirely,
> > because the packages have been bumped and rebuilt several times.
> >
> >   http://fedoraproject.org/wiki/Package_Renaming_Process
> >   https://fedoraproject.org/wiki/How_to_remove_a_package_at_end_of_life
> >
> > If you need help, feel free to contact me.
> Yes, I am afraid I need help. I don’t understand what this is about.
> Probably it has something to do with the
>     Provides:   ibus-hunspell-table = %{version}-%{release}
>     Obsoletes:  ibus-hunspell-table <= 0.0.6-1.fc17
>     Provides:   ibus-hunspell-table = %{version}-%{release}
>     Obsoletes:  ibus-hunspell-table <= 0.0.8-2.fc18
>     Provides:   ibus-indic-table = %{version}-%{release}
>     Obsoletes:  ibus-indic-table <= 1.3.1-23.fc17
>     ...
> lines in in the .spec file.
> I believe these packages are gone since at least summer 2012.

They haven't been retired or blocked and get rebuilt during mass-rebuilds.

> So what do I have to do now.

Visit above Wiki pages and retire the obsolete packages properly
for Rawhide _and_ Fedora 20 (since that is still possible, too).

Complete all steps as explained in the Wiki.
It is important to block/withdraw the obsolete builds also from F20.
For older dists, packages cannot be pulled anymore.

Afterwards, fix the Obsoletes tag in "ibus-typing-booster".
Prefer "less than" over "less than or equal" in the Obsoletes tags.
Don't use the dist tag in the specified version-release values.
Specify the _next_ Release value that is higher than the Release prefix
of the last published build. If not doing that, even a minor update for
the old dists would break the Obsoletes tag.
Add only a single pair of Provides/Obsoletes per package.

The following would be safe, provided that the packages get blocked from F20:

  Obsoletes: ibus-european-table < 1.1.6-5
  Obsoletes: ibus-hunspell-table < 0.0.8-5

I offer to send you a full cleanup patch for current git, after you manage
to retire and block the obsolete packages.


More information about the devel mailing list