Broken dependencies: libdmtx => ImageMagick soname bump

Dan Horák dan at danny.cz
Tue Apr 1 08:29:01 UTC 2014


On Mon, 31 Mar 2014 13:37:51 +0000 (UTC)
buildsys at fedoraproject.org wrote:

> 
> 
> libdmtx has broken dependencies in the rawhide tree:
> On x86_64:
> 	libdmtx-utils-0.7.2-11.fc20.x86_64 requires libMagickWand-6.Q16.so.1()(64bit)
> 	libdmtx-utils-0.7.2-11.fc20.x86_64 requires libMagickCore-6.Q16.so.1()(64bit)
> On i386:
> 	libdmtx-utils-0.7.2-11.fc20.i686 requires libMagickWand-6.Q16.so.1
> 	libdmtx-utils-0.7.2-11.fc20.i686 requires libMagickCore-6.Q16.so.1
> On armhfp:
> 	libdmtx-utils-0.7.2-11.fc20.armv7hl requires libMagickWand-6.Q16.so.1
> 	libdmtx-utils-0.7.2-11.fc20.armv7hl requires libMagickCore-6.Q16.so.1
> Please resolve this as soon as possible.

there seems to be an unannounced soname bump in ImageMagick in rawhide,
but the same release is going to F-20 too. Per changelog the reason is
mainly fixing multiple CVEs, but a rebuild of all dependent packages
will be required.

http://pkgs.fedoraproject.org/cgit/ImageMagick.git/log/
http://koji.fedoraproject.org/koji/buildinfo?buildID=508129


		Dan


More information about the devel mailing list