Considering GNOME 3.12 as an F20 update

Jaroslav Reznik jreznik at redhat.com
Mon Apr 7 08:28:38 UTC 2014


----- Original Message -----
> On Thu, 2014-04-03 at 22:34 -0500, Rex Dieter wrote:
> > The gnome-3.12 copr includes a couple of low-level package updates
> > that
> > change abi/api that affects other desktops, notably:
> > upower-0.99
> > PackageKit-0.9.x
> > 
> > Are these 2 required by gnome-3.12 or would it be possible to use the
> > (current) f20 versions?
> 
> PackageKit should not need to be updated. upower will be a small
> problem. GNOME might need to be patched to use the older upower in F20
> (or the other desktops could be patched to use the newer upower).

I'd prefer to limit updates to GNOME only, so it would be desirable to
get GNOME patched. It's easier to test if one desktop works well when
patched than trying to test the whole world of other desktops (and
probably forget something). So make this change self-contained rather
than system wide.

Otherwise I'm in favour of updates, these days it's pretty standard
to even change the UI during life cycle of product and actually, users
usually call for it (recently for example the OS in my STB changed
from scratch and I was eagerly waiting for it ;-). Of course, it needs
to be communicated to users.

Jaroslav 

> 
> --
> devel mailing list
> devel at lists.fedoraproject.org
> https://admin.fedoraproject.org/mailman/listinfo/devel
> Fedora Code of Conduct: http://fedoraproject.org/code-of-conduct


More information about the devel mailing list