F21 system GCC changed to 4.9.0 prerelease

Zoltan Boszormenyi zboszor at freemail.hu
Sat Apr 12 09:41:48 UTC 2014

2014-04-10 19:38 keltezéssel, Orion Poplawski írta:
> On 04/10/2014 04:23 AM, Jakub Jelinek wrote:
>> Hi!
>> FYI, gcc in rawhide has been upgraded to 4.9.0 prerelease,
>> please visit http://gcc.gnu.org/gcc-4.9/porting_to.html if your
>> package no longer builds.  To investigate runtime rather than compile time
>> issues, please consider using temporarily -fsanitize=undefined and/or
>> -fsanitize=address to look for undefined behavior in the packages
>> you own.
>> 	Jakub
> I think I've found a regression in gfortran with list-directed reading
> from character arrays: http://gcc.gnu.org/bugzilla/show_bug.cgi?id=60810
> unless this is some kind of new standards compliance, but this seems to
> have worked forever.

Any project I tried with
    ./configure CFLAGS="-fsanitize=undefined -fsanitize=address"
fails with:

checking for gcc... gcc
checking whether the C compiler works... no

config.log reveals that libasan.so and libubsan.so are missing from the system.
"yum install lib{a,ub}san.{i686,x86_64}" fixed it. Shouldn't gcc and gcc-c++
packages require these libraries?

Best regards,
Zoltán Böszörményi

More information about the devel mailing list