Orphaning java-1.5.0-gcj

Simo Sorce simo at redhat.com
Mon Apr 14 14:32:46 UTC 2014


On Mon, 2014-04-14 at 09:44 +0200, Stanislav Ochotnicky wrote:
> On Sun 13 Apr 2014 08:42:43 PM CEST Simo Sorce wrote:
> > [snip] I know little to nothing about java bindings so if it is
> > substantial work I will just remove the java binding and ask rel eng to
> > pull the subpackage.
> 
> You can't just "pull" packages. You'll have to properly "Obsoletes:
> lasso-java" it. I am attaching a patch which worked for me (including a
> scratchbuild with openjdk). I haven't actually tested the code, but I
> guess it should work (it's JNI though so...meh)
> 
> A side note: I believe we generally start release numbering at 1 instead
> of 0, but of course it doesn't hurt anything...

Ok the patch worked fine for building on my F20, which I did as a test,
however it failed the build in rawhide.

The only clue I can get is this:
configure: WARNING: unable to include <jni.h>

however I got the same warning in F20 w/o causing the build to fail.

Here build fails in the sense that the configure script thinks there is
no java available at all and just skips building the jni stuff and then
rpm fails to find the .so and .jar files.

Help ?

Simo.

-- 
Simo Sorce * Red Hat, Inc * New York



More information about the devel mailing list