F21 System Wide Change: Ruby193 in SCL

Vít Ondruch vondruch at redhat.com
Tue Apr 15 08:21:56 UTC 2014


Dne 15.4.2014 02:07, T.C. Hollingsworth napsal(a):
> On Mon, Apr 14, 2014 at 7:16 AM, Jaroslav Reznik <jreznik at redhat.com> wrote:
>> Rails depends on exact v8
>> version, which means v8 3.14 must have also their own SCL as part of the SCL.
> Stupid question: what in rails depends on v8 exactly?
>
> The only thing that Requires v8 in Fedora besides nodejs and mongodb
> is rubygem-therubyracer, and that FTBFS for the F20 mass rebuild and
> my recent v8/libicu mini-mass rebuild:
> http://koji.fedoraproject.org/koji/packageinfo?packageID=14305
>
> I'm in touch with someone from IBM to get PPC support for v8/nodejs
> (which means no more random failures when nodejs packages get sent to
> EPEL PPC builders, yay!), which requires finally switching to gyp from
> scons (which has been deprecated for years now), and so far I've been
> ignoring ruby in my preliminary work [1] on this since it has been
> broken for other reasons.

The "other reasons" were update of v8 from 3.13 to 3.14.

Vít

>
> If you're going to continue to need rubygem-therubyracer, please fix
> it so I can make sure we don't break it.  (Or at least rebuild it when
> the time comes.  It probably still works in F20 since nothing changed
> v8-wise since F18, but I wouldn't be surprised if it's completely
> busted in rawhide right now.)
>
> Thanks,
> -T.C.
>
> [1] http://copr.fedoraproject.org/coprs/patches/v8-gyp/



More information about the devel mailing list