Python 3 and mod_wsgi

Matthias Runge mrunge at matthias-runge.de
Wed Apr 16 09:07:06 UTC 2014


On 04/15/2014 01:08 PM, Joe Orton wrote:
> On Mon, Apr 14, 2014 at 04:54:33PM -0400, Bohuslav Kabrda wrote:
>> AFAIK you can't have 2 mod_wsgi's, each one compiled against a
>> different Python major.minor, loaded by Apache at the same time for
>> various reasons. So the best solution would IMO be to create
>> python3-mod_wsgi (subpackage of mod_wsgi), that would conflict with
>> mod_wsgi. It should be perfectly doable and it shouldn't break
>> anything. CCing Matthias, the owner of mod_wsgi in Fedora - Matthias,
>> what do you think?
>
> This is done in f21 already thanks to Jakub Dorňák (#1035876) - I guess
> we could backport to f20 without any problems.
>

Sorry for jumping in so late here, I'm currently on PTO and nearly 
excluded from the net.

To the question: yes, there is already a patch for f21 and it makes 
sense to backport it. There's also a bz ticket requesting exactly 
that[1]. I also saw Toshios additions and his bz ticket[2] to track the 
conflicts issue.

I simply didn't found the time to do so, but will look onto that, when 
I'm back. If anyone wants to do this earlier, please go ahead!

Best,
Matthias


[1] https://bugzilla.redhat.com/show_bug.cgi?id=1082109
[2] https://bugzilla.redhat.com/show_bug.cgi?id=1087943


More information about the devel mailing list