F21 System Wide Change: BerkeleyDB 6

Miloslav Trma─Ź mitr at volny.cz
Thu Apr 24 15:39:50 UTC 2014


2014-04-24 17:22 GMT+02:00 Jerry James <loganjerry at gmail.com>:

> On Thu, Apr 24, 2014 at 8:50 AM, Kevin Fenzi <kevin at scrye.com> wrote:
> > Yeah, which makes technical sense... but the concern is packagers who
> > aren't paying attention rebuild for some other reason and are not on v6
> > when it's a licensing problem. ;(
>
> I need some advice on how to handle this for XEmacs, which is a GPLv3+
> package.  It provides some optional database functionality, but the
> underlying database can be any of libdb, gdbm, or postgresql.  When I
> first turned this on for Fedora, in response to a request in bz
> 581614, I chose libdb for reasons that I no longer remember.  So now I
> need to choose between:
> - libdb (going to AGPLv3+)
> - gdbm (GPLv3+)
> - postgresql (PostgreSQL, essentially MIT)
>
You'll have the option of moving to libdb5 , without a license change or
need to convert data.  That should be easiest, at least in the medium term
while libdb5 is actively maintained.
    Mirek
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.fedoraproject.org/pipermail/devel/attachments/20140424/0d622e64/attachment.html>


More information about the devel mailing list