"Tick-tock" release cadence?

Bruno Wolff III bruno at wolff.to
Sat Dec 6 15:37:34 UTC 2014


On Sat, Dec 06, 2014 at 07:25:48 +0100,
  Kevin Kofler <kevin.kofler at chello.at> wrote:
>
>And unfortunately, a new PostgreSQL IS incompatible, because if you just run
>"yum update", your databases will cease to work. You have to actually dump
>them BEFORE doing the upgrade (or downgrade PostgreSQL for the dump, or
>install the old version in parallel, which is not supported by the RPMs),
>then do the upgrade, and then import the dump. As long as upstream does not
>change this migration policy, it will NEVER be possible to provide newer
>PostgreSQL release series un updates.

Recent versions of Postgresql do let you upgrade the data. But that entails 
some risk. Also changes could break applications or configuration for it. 
So while it can be a bit more covenient to do an upgrade now then it was 
it the past, this is still something you don't want to have forced upon you.


More information about the devel mailing list