F20: Puppet depchain pulls in Java

Michael Stahnke stahnma at puppetlabs.com
Sat Jan 18 06:40:07 UTC 2014


On Fri, Jan 17, 2014 at 6:53 PM, Rahul Sundaram <metherid at gmail.com> wrote:
> Hi
>
>
> On Fri, Jan 17, 2014 at 9:43 PM, Mo Morsi  wrote:
>>
>> Yes as others have mentioned puppet requires ruby(release) which is
>> satisfied by both ruby-mri and jruby

So should it just require ruby-mri?

The divergence from the way upstreams handle ruby here is quite
difficult to work with. I find ruby-pick and bundler patching to be
less fun/friendly than having what I'd expect form upstream. I'm not
in love with the way upstream handles/does things, but I don't really
understand what happened to the 'upstream first' mantra. Here we
(Fedora) just made up their own rules and moved forward.


>
>
> ... which is fine.  However yum install puppet should be pulling in only
> one.  Not both.  I would say almost everybody would expect that to be
> ruby-mri

I would say exactly everybody, since on jruby there are issues.


More information about the devel mailing list