SELinux RPM scriplet issue annoucement

Simo Sorce simo at redhat.com
Mon Jan 20 04:02:24 UTC 2014


On Mon, 2014-01-20 at 00:14 +0100, Michael Schwendt wrote:
> Anyone not aware of the problem and the fix, who applies the -117.fc20
> selinux-policy update in _enforcing_ mode (since it has entered stable
> updates meanwhile) believing it to be a normal update, will face another
> failure and a partial update. Package selinux-policy updated
> to -117.fc20 but -targeted remaining at -116.fc20.

I don't see this.
I just updated today before reading this message (and I haven;t read the
whole thread, sorry) and I got selinux-policy and targeted updated
without any problem (I always run in enforcing mode).

Simo.

> Fixing that with the instructions in the Wiki wouldn't work, 
> 
>   # yum update selinux-policy
>   Loaded plugins: auto-update-debuginfo, langpacks, refresh-packagekit
>   No packages marked for update
> 
> since selinux-policy package is up-to-date. The enhanced fix that adds
> '\*' works also for this extra problem:
> 
>   setenforce 0
>   yum clean expire-cache
>   yum update selinux-policy\*
>   setenforce 1
> 
> [...]

[snip]

-- 
Simo Sorce * Red Hat, Inc * New York



More information about the devel mailing list