runuser error in a docker container on rawhide

Robert Rati rrati at
Wed Jun 4 19:17:10 UTC 2014

I checked the status of selinux in the container and it was disabled, so 
I don't think that's the problem.  I then tried re-launching the 
container in privileged mode (--privileged=true) and that didn't change 
anything.  The runuser command still prints "System error" if I use it 
to do anything, even nothing.


On 06/04/2014 02:37 PM, Daniel J Walsh wrote:
> On 06/04/2014 02:27 PM, Robert Rati wrote:
>> I'm trying to run some docker containers and it appears the runuser in
>> rawhide isn't functional in the container:
>> # runuser
>> runuser: System error
>> I can run runuser in a physical system running rawhide however.  These
>> same images created off of F20 containers worked fine.
>> Has anyone run into this?  Any ideas?
>> Rob
> I would guess it is potentially SELinux or /proc being readonly.
> Put the machine into permissive mode to see if it is SELinux, (I doubt it).
> You could check with a priv container to see if /proc or capabilities ar
> ethe problem.

More information about the devel mailing list