runuser error in a docker container on rawhide

Daniel J Walsh dwalsh at
Wed Jun 4 20:34:57 UTC 2014

On 06/04/2014 04:03 PM, Robert Rati wrote:
> I'm pretty baffled.  I've successfully used runuser with F20 as the
> host and F20 in the container.  Something is different in rawhide.  I
> even tried downgrading util-linux in the container to the latest
> version in F20 and I still get the same error, which leads me to
> believe it's not util-linux at all.  The docker version in rawhide is
> newer (I'm running rawhide host and rawhide in the container), but I
> wouldn't expect that to affect runuser.
> Rob
It looks like /dev/log is not being created.

> On 06/04/2014 03:54 PM, Daniel J Walsh wrote:
>> On 06/04/2014 03:17 PM, Robert Rati wrote:
>>> I checked the status of selinux in the container and it was disabled,
>>> so I don't think that's the problem.  I then tried re-launching the
>>> container in privileged mode (--privileged=true) and that didn't
>>> change anything.  The runuser command still prints "System error" if I
>>> use it to do anything, even nothing.
>>> Rob
>>> On 06/04/2014 02:37 PM, Daniel J Walsh wrote:
>>>> On 06/04/2014 02:27 PM, Robert Rati wrote:
>>>>> I'm trying to run some docker containers and it appears the
>>>>> runuser in
>>>>> rawhide isn't functional in the container:
>>>>> # runuser
>>>>> runuser: System error
>>>>> I can run runuser in a physical system running rawhide however. 
>>>>> These
>>>>> same images created off of F20 containers worked fine.
>>>>> Has anyone run into this?  Any ideas?
>>>>> Rob
>>>> I would guess it is potentially SELinux or /proc being readonly.
>>>> Put the machine into permissive mode to see if it is SELinux, (I
>>>> doubt it).
>>>> You could check with a priv container to see if /proc or
>>>> capabilities ar
>>>> ethe problem.
>> Strange testing on rhel7 I see it working.
>> # docker run --rm -ti fedora runuser -u ftp id
>> uid=14(ftp) gid=50(ftp) groups=50(ftp)

More information about the devel mailing list