yum install kernel-devel Installing & dnf install kernel-devel Upgrading

poma pomidorabelisima at gmail.com
Thu Jun 26 17:47:09 UTC 2014


On 26.06.2014 09:39, Ales Kozumplik wrote:

> Hello,
>
> The globbing mechanism in DNF is still evolving and it is possible you
> are running into one of the cases that we omitted to implement. Or
> perhaps there is a different problem. Can I ask you to file a bug using
>
> https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&component=dnf
>
> so the issue is tracked and when the time comes one of us working on DNF
> can take a look at it in detail?
>
> For further information kindly take a look at:
>
> http://fedoraproject.org/wiki/How_to_file_a_bug_report
>
> Thanks!
>
> Ales
>

Of course you can always ask and hope as I have done many times before. ;)
Looks like Batman poking around Rawhide repo. :)
Actually this[1] problem is now identical to the one was with the 'kernel-modules-extra'.


/etc/yum.repos.d/fedora-rawhide-koji.repo
[rawhide-koji]
name=Fedora $releasever - $basearch - Koji
baseurl=http://koji.fedoraproject.org/repos/f$releasever-build/latest/$basearch/
enabled=0
gpgcheck=0
skip_if_unavailable=True


# yum --disablerepo \* --enablerepo rawhide-koji update kernel\* \*perf
Loaded plugins: langpacks
Resolving Dependencies
--> Running transaction check
---> Package kernel.i686 0:3.16.0-0.rc2.git2.1.fc21 will be installed
---> Package kernel-core.i686 0:3.16.0-0.rc2.git2.1.fc21 will be installed
---> Package kernel-devel.i686 0:3.16.0-0.rc2.git2.1.fc21 will be installed
---> Package kernel-headers.i686 0:3.16.0-0.rc2.git0.1.fc21 will be updated
---> Package kernel-headers.i686 0:3.16.0-0.rc2.git2.1.fc21 will be an update
---> Package kernel-modules.i686 0:3.16.0-0.rc2.git2.1.fc21 will be installed
---> Package kernel-modules-extra.i686 0:3.16.0-0.rc2.git2.1.fc21 will be installed
---> Package kernel-tools.i686 0:3.16.0-0.rc2.git0.1.fc21 will be updated
---> Package kernel-tools.i686 0:3.16.0-0.rc2.git2.1.fc21 will be an update
---> Package kernel-tools-libs.i686 0:3.16.0-0.rc2.git0.1.fc21 will be updated
---> Package kernel-tools-libs.i686 0:3.16.0-0.rc2.git2.1.fc21 will be an update
---> Package kernel-tools-libs-devel.i686 0:3.16.0-0.rc2.git0.1.fc21 will be updated
---> Package kernel-tools-libs-devel.i686 0:3.16.0-0.rc2.git2.1.fc21 will be an update
---> Package perf.i686 0:3.16.0-0.rc2.git0.1.fc21 will be updated
---> Package perf.i686 0:3.16.0-0.rc2.git2.1.fc21 will be an update
---> Package python-perf.i686 0:3.16.0-0.rc2.git0.1.fc21 will be updated
---> Package python-perf.i686 0:3.16.0-0.rc2.git2.1.fc21 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

==========================================================================================
       Package                     Arch     Version                      Repository        Size
==========================================================================================
Installing:
       kernel                      i686     3.16.0-0.rc2.git2.1.fc21     rawhide-koji      86 k
       kernel-core                 i686     3.16.0-0.rc2.git2.1.fc21     rawhide-koji      18 M
       kernel-devel                i686     3.16.0-0.rc2.git2.1.fc21     rawhide-koji     9.0 M
       kernel-modules              i686     3.16.0-0.rc2.git2.1.fc21     rawhide-koji      16 M
       kernel-modules-extra        i686     3.16.0-0.rc2.git2.1.fc21     rawhide-koji     2.2 M
Updating:
       kernel-headers              i686     3.16.0-0.rc2.git2.1.fc21     rawhide-koji     985 k
       kernel-tools                i686     3.16.0-0.rc2.git2.1.fc21     rawhide-koji     168 k
       kernel-tools-libs           i686     3.16.0-0.rc2.git2.1.fc21     rawhide-koji      92 k
       kernel-tools-libs-devel     i686     3.16.0-0.rc2.git2.1.fc21     rawhide-koji      88 k
       perf                        i686     3.16.0-0.rc2.git2.1.fc21     rawhide-koji     1.0 M
       python-perf                 i686     3.16.0-0.rc2.git2.1.fc21     rawhide-koji     179 k

Transaction Summary
==========================================================================================
Install  5 Packages
Upgrade  6 Packages

Total download size: 48 M
Is this ok [y/d/N]: y


# dnf --disablerepo \* --enablerepo rawhide-koji update kernel\* \*perfFailed loading plugin: copr
Dependencies resolved.

==========================================================================================
       Package                     Arch     Version                      Repository        Size
==========================================================================================
Installing:
       kernel                      i686     3.16.0-0.rc2.git2.1.fc21     rawhide-koji      86 k
       kernel-core                 i686     3.16.0-0.rc2.git2.1.fc21     rawhide-koji      18 M
       kernel-modules              i686     3.16.0-0.rc2.git2.1.fc21     rawhide-koji      16 M
       kernel-modules-extra        i686     3.16.0-0.rc2.git2.1.fc21     rawhide-koji     2.2 M
Upgrading:
       ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
       kernel-devel                i686     3.16.0-0.rc2.git2.1.fc21     rawhide-koji     9.0 M
       ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
       kernel-headers              i686     3.16.0-0.rc2.git2.1.fc21     rawhide-koji     985 k
       kernel-tools                i686     3.16.0-0.rc2.git2.1.fc21     rawhide-koji     168 k
       kernel-tools-libs           i686     3.16.0-0.rc2.git2.1.fc21     rawhide-koji      92 k
       kernel-tools-libs-devel     i686     3.16.0-0.rc2.git2.1.fc21     rawhide-koji      88 k
       perf                        i686     3.16.0-0.rc2.git2.1.fc21     rawhide-koji     1.0 M
       python-perf                 i686     3.16.0-0.rc2.git2.1.fc21     rawhide-koji     179 k

Transaction Summary
==========================================================================================
Install  4 Packages
Upgrade  7 Packages

Total download size: 48 M
Is this ok [y/N]: N
Exiting on user Command


[1]  kernel-devel != Upgrading
      kernel-devel == Installing


poma




More information about the devel mailing list