Heads-up on rpm 4.12 coming to rawhide soon

Vít Ondruch vondruch at redhat.com
Mon Jun 30 13:27:02 UTC 2014


Dne 30.6.2014 15:14, Panu Matilainen napsal(a):
> On 06/30/2014 03:48 PM, Panu Matilainen wrote:
>> On 06/30/2014 03:12 PM, Vít Ondruch wrote:
>>> Interesting, it breaks Ruby build it seems:
>>>
>>> http://koji.fedoraproject.org/koji/taskinfo?taskID=7090194
>>>
>>> Not sure about the reason, though.
>>
>> Seems the ruby macros are not expanding properly throughout the spec,
>> please file a bug.
>
> I'd call this at least partially self-inflicted pain, its the %load 
> trickery thats failing. Call your own version of %load something else 
> and it'll work like before.
>
> The syntax for the built-in macro is %{load:<file>} but the argument 
> is not macro expanded so %{SOURCEn} will get passed in literally. 
> Which obviously wont work.
>
>     - Panu -
>

Yes, that will do the trick probably.

However, now I am wondering, is there a way how to build SRPM, which is 
using the new load feature from 4.12 using old 4.11 RPM? With old RPM, 
I've got this error:

```
$ fedpkg srpm
error: line 94: Unknown tag: 
/home/vondruch/fedora-scm/maintain/ruby/macros.ruby
error: query of specfile 
/home/vondruch/fedora-scm/maintain/ruby/ruby.spec failed, can't parse

Could not execute srpm: need more than 0 values to unpack
```

I suppose the answer is NO, but I hope for some pleasant surprise ;)



Vít


More information about the devel mailing list