Heads up: Mesa/LLVM rebase and OpenGTL retirement in F20

Adam Jackson ajax at redhat.com
Thu Mar 27 20:02:35 UTC 2014


We'd like to update to Mesa 10.1 in Fedora 20, since the cycle is so
long before F21 and (among other goodies) it enables OpenGL 3.3 on some
newer Radeons.  This implies rebasing LLVM 3.4, and that's where it gets
a little awkward: the OpenGTL package only works up to LLVM 3.3.

However, OpenGTL is dead upstream, and the only thing requiring it in
F20 gold - calligra-krita, by way of libQtGTL - has already been updated
to Obsolete OpenGTL.  As far as I know OpenGTL is the only such package
we have requiring LLVM 3.3, so the rest of the rebase should just be a
matter of updating to match F21.

The following source packages will also be updated for the llvm rebase:

dragonegg
gambas3
pocl
pure
python-llvmpy

If there are no serious objections I'll try to get this all into testing
early next week.  If you _do_ happen to be using OpenGTL for something
in F20, now would be an excellent time for you to start working on
porting it to current LLVM.

- ajax



More information about the devel mailing list