Running docker in a mock chroot

Dridi Boukelmoune dridi.boukelmoune at
Wed Nov 5 22:45:45 UTC 2014


I haven't really tried, I only wanted to look at fig 1.0 currently in
f21 updates-testing. So I --shell'ed inside my fedora-21-x86_64
mock chroot after installing fig, and tried to start a docker daemon
in the background but it failed.

   # docker -d -H unix:///var/run/docker.sock &
   2014/11/05 23:08:33 docker daemon: 1.3.0 c78088f/1.3.0; execdriver:
   native; graphdriver:
   [45f3a6fd] +job serveapi(unix:///var/run/docker.sock)
   [error] attach_loopback.go:42 There are no more loopback devices available.
   2014/11/05 23:08:33 loopback mounting failed

If I need to use a VM, I will (any news for vagrant?) but I was
wondering whether this was actually possible. I haven't looked in
detail at how mock creates the chroots, and don't have time to dig
at all these days.

I was just wondering whether it was actually possible to run docker
in a chroot, especially one built with mock!


More information about the devel mailing list