Running docker in a mock chroot

Josef Stribny jstribny at
Thu Nov 6 07:34:30 UTC 2014

> If I need to use a VM, I will (any news for vagrant?) 

The f20 Copr[0] should pretty much work, and we are close to finalize a package for f22
(we have some bundler issues we need to workaround).



----- Original Message -----
From: "Dridi Boukelmoune" <dridi.boukelmoune at>
To: "Development discussions related to Fedora" <devel at>, fig-owner at
Sent: Wednesday, November 5, 2014 11:45:45 PM
Subject: Running docker in a mock chroot


I haven't really tried, I only wanted to look at fig 1.0 currently in
f21 updates-testing. So I --shell'ed inside my fedora-21-x86_64
mock chroot after installing fig, and tried to start a docker daemon
in the background but it failed.

   # docker -d -H unix:///var/run/docker.sock &
   2014/11/05 23:08:33 docker daemon: 1.3.0 c78088f/1.3.0; execdriver:
   native; graphdriver:
   [45f3a6fd] +job serveapi(unix:///var/run/docker.sock)
   [error] attach_loopback.go:42 There are no more loopback devices available.
   2014/11/05 23:08:33 loopback mounting failed

If I need to use a VM, I will (any news for vagrant?) but I was
wondering whether this was actually possible. I haven't looked in
detail at how mock creates the chroots, and don't have time to dig
at all these days.

I was just wondering whether it was actually possible to run docker
in a chroot, especially one built with mock!

devel mailing list
devel at
Fedora Code of Conduct:

More information about the devel mailing list