Running docker in a mock chroot

Miroslav Suchý msuchy at
Thu Nov 6 09:31:31 UTC 2014

On 11/05/2014 11:45 PM, Dridi Boukelmoune wrote:
> I haven't really tried, I only wanted to look at fig 1.0 currently in
> f21 updates-testing. So I --shell'ed inside my fedora-21-x86_64
> mock chroot after installing fig, and tried to start a docker daemon
> in the background but it failed.

--shell was never meant as "give me isolated environment for my dirty testing". It is present in mock, to give you 
ability to investigate what is wrong with your failing builds and debug your scriptlets.

> detail at how mock creates the chroots,

It just create some files needed to run builds , symlink few /proc files and chroot there. Nothing less, nothing more.

Since version mock-1.2.0 there is new option --new-chroot, which will use systemd-nspawn instead of chroot.
It is not enabled by default as it breaks some existing scripts.

Miroslav Suchy, RHCE, RHCDS
Red Hat, Senior Software Engineer, #brno, #devexp, #fedora-buildsys

More information about the devel mailing list