Multiple problems with multiple monitors

Basil Mohamed Gohar basilgohar at librevideo.org
Tue Oct 14 02:53:56 UTC 2014


On 10/13/2014 05:18 PM, David Airlie wrote:
> 
>>
>>
>> I've searched for bugs related to the specific problems I've been having, and
>> I've not been able to find anything that describes what I'm seeing.
>>
>> I have an HP EliteBook 840 that also comes with an UltraDock, to which I've
>> plugged-in two external monitors and I use in conjunction with the built-in
>> laptop display.
> 
> What Fedora distro are you using?
> 
> Does this laptop have multiple GPUs? what GPU is it etc.
> 
> You probably should file a bug against the primary GPU with the dmesg.
> 
>> Issue #2: When I undock my laptop while logged-in, Gnome Shell just crashes.
>> When I redock after the laptop has been started when unconnected, one of the
>> two external monitors start-up (the one connected by VGA), but not the one
>> connected by a DisplayPort connection. And, recently (but not when I first
>> started using this laptop with the dock, which was about a month ago), now
>> when I start-up with the laptop docked and both external monitors connected,
>> both external monitors will be active, but the built-in display will show
>> nothing. Gnome Shell reports the built-in display is active, but will not
>> display anything unless I deactivate it and reactivate it via the settings
>> "Displays" utility.
> 
> This sounds like MST releated but I can't say without more info.
> 
> Dave.
> 

Thanks, Dave, I was hoping you'd see this. :)

The laptop has two GPUs, one Intel and the other Radeon.  I am not sure
how to tell which display is controlled by which device.

It is Fedora 20.  I can get you more details when I get back to work
tomorrow.  I'm happy to provide whatever information is necessary, but
that is part of the problem, I'm not sure what is useful to help figure
this out.

-- 
Libre Video
http://librevideo.org


More information about the devel mailing list