rawhide report: 20141028 changes

Adam Jackson ajax at redhat.com
Tue Oct 28 15:10:56 UTC 2014


On Tue, 2014-10-28 at 10:57 +0000, Fedora Rawhide Report wrote:

> [dragonegg]
> 	dragonegg-3.4-0.3.rc0.fc21.i686 requires libLLVM-3.4.so
> 	dragonegg-3.4-0.3.rc0.fc21.i686 requires gcc = 0:4.8.2-14.fc21

This one's a joy.  dragonegg is a gcc plugin that basically replaces the
middle and back ends; gcc's parser, llvm's optimizers, llvm's code
generators.  There's a dragonegg 3.5.0 to match llvm 3.5.0, but since
gcc's plugin API is just as unstable as llvm's, it only supports through
gcc 4.8.

But dragonegg is busted in F21 already, because (as above) it was built
against gcc 4.8 and F21 is gcc 4.9.  Can we block or retire dragonegg?

- ajax



More information about the devel mailing list