Systemd, Spamassassin, and the Missing Portreserve Package

Reindl Harald h.reindl at
Thu Feb 5 20:58:32 UTC 2015

Am 05.02.2015 um 21:56 schrieb Tom Rivers:
> While configuring a new Fedora 21 workstation yesterday evening, I ran
> into something that I found interesting.  I installed Spamassassin,
> tried to start it, and got the following entry in the logs:
> systemd: Failed at step EXEC spawning /sbin/portrelease: No such file or
> directory
> After checking "yum whatprovides /sbin/portrelease", I found it
> referenced portreserve-0.0.5-11.fc21.x86_64 which was not installed with
> Spamassassin as a dependency.  Just for kicks, I looked for portrelease
> in the relevant systemd directory and found only Spamassassin was using it:
> # grep -R portrelease /usr/lib/systemd/system
> /usr/lib/systemd/system/spamassassin.service:ExecStartPre=-/sbin/portrelease
> spamd
> Does anyone know if this behavior is expected?  The fix is easy enough,
> but I figured I should ask just in case it's not by design

why in the world does SA need portreserve?

frankly i write a meta-package for F20 to get rid of portreserve and all 
it's dependecnies on the inbound MX by yojust provide it with a random RPM

too lazy now to search my bugreport why it was pulled at all

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 181 bytes
Desc: OpenPGP digital signature
URL: <>

More information about the devel mailing list