Results of a test mass rebuild of rawhide/x86_64 with gcc-5.0.0-0.5.fc22

Michael Schwendt mschwendt at gmail.com
Mon Feb 16 14:10:55 UTC 2015


On Sun, 15 Feb 2015 23:14:33 +0100, Jakub Jelinek wrote:

> On Sun, Feb 15, 2015 at 11:08:55PM +0100, Michael Schwendt wrote:
> > On Sun, 8 Feb 2015 18:17:56 +0100, Marek Polacek wrote:
> > 
> > > either package bugs, or GCC bugs.  As things stand, just about 19 packages did
> > > not build due to bugs in gcc-5.0.0-0.5.fc22.  All GCC bugs except one are fixed
> > > at this time, and I promise I will fix the remaining one before long.
> > 
> > gcc-5.0.0-0.13.fc23 fails for Audacious 3.6-beta1 as tried in Copr:
> > 
> >   https://copr.fedoraproject.org/coprs/mschwendt/audacious-next/build/72152/
> > 
> > As I haven't had a chance to look into it, Audacious upstream believes
> > it to be a C++ bug in GCC.
> 
> File a bugreport with preprocessed source?

For that I would need a Rawhide installation and time to look into it
and the constexpr C++14 changes in GCC 5.

The same src.rpm builds fine on Fedora 21 (and also with Clang), so for a
constexpr expert it would be much easier to draw conclusions.


More information about the devel mailing list