updates-testing: multilib broken for days now

Reindl Harald h.reindl at thelounge.net
Wed Jul 8 19:30:40 UTC 2015


--> Running transaction check
---> Package polkit-libs.x86_64 0:0.113-1.fc21 will be installed
---> Package udisks2.x86_64 0:2.1.3-4.fc21 will be updated
---> Package udisks2.x86_64 0:2.1.3-4.fc21 will be updated
---> Package udisks2.x86_64 0:2.1.6-1.fc21 will be an update
--> Processing Dependency: libudisks2(x86-64) = 2.1.6-1.fc21 for 
package: udisks2-2.1.6-1.fc21.x86_64
--> Running transaction check
---> Package libudisks2.x86_64 0:2.1.3-4.fc21 will be updated
---> Package libudisks2.x86_64 0:2.1.6-1.fc21 will be an update
--> Finished Dependency Resolution
--> Finding unneeded leftover dependencies
Found and removing 0 unneeded dependencies
Error:  Multilib version problems found. This often means that the root
        cause is something else and multilib version checking is just
        pointing out that there is a problem. Eg.:

          1. You have an upgrade for polkit which is missing some
             dependency that another package requires. Yum is trying to
             solve this by installing an older version of polkit of the
             different architecture. If you exclude the bad architecture
             yum will tell you what the root cause is (which package
             requires what). You can try redoing the upgrade with
             --exclude polkit.otherarch ... this should give you an error
             message showing the root cause of the problem.

          2. You have multiple architectures of polkit installed, but
             yum can only see an upgrade for one of those architectures.
             If you don't want/need both architectures anymore then you
             can remove the one with the missing update and everything
             will work.

          3. You have duplicate versions of polkit installed already.
             You can use "yum check" to get yum show these errors.

        ...you can also use --setopt=protected_multilib=false to remove
        this checking, however this is almost never the correct thing to
        do as something else is very likely to go wrong (often causing
        much more problems).

        Protected multilib versions: polkit-0.113-1.fc21.x86_64 != 
polkit-0.112-7.fc21.1.i686

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 181 bytes
Desc: OpenPGP digital signature
URL: <http://lists.fedoraproject.org/pipermail/devel/attachments/20150708/8de9fe41/attachment.sig>


More information about the devel mailing list