dnf doesn't check for rpmdb lock?

Przemek Klosowski przemek.klosowski at nist.gov
Thu Jul 16 17:42:46 UTC 2015


On 07/16/2015 01:19 PM, Eric Griffith wrote:
>
> I tried to do an install and an update on two different terminals on 
> my machine yesterday. The second one didn't yell about an rpmdb lock 
> but it did say that it was waiting on a process. So unless it broke 
> from an update last night / this morning then idk
>
> On Jul 16, 2015 11:20 AM, "Richard Shaw" <hobbes1069 at gmail.com 
> <mailto:hobbes1069 at gmail.com>> wrote:
>
>     I remember frequently (to my dismay) getting messages from yum
>     saying that another process had a lock on the RPM database.
>
>     Due to a recent rash of issues with the akmods package I have been
>     investigating why the kmods are not getting installed.
>
>     Out of curiosity I tried running two dnf update instances in two
>     different terminals and I did not get the message, in fact it
>     acted like nothing was wrong!
>
>

So I just did 'dnf update' from two different terminals on the same 
system and allowed the first one to proceed. While it was updating, I 
kept running 'dnf update' in the other terminal, terminating it by not 
giving it an OK to proceed.

The second 'dnf update'  was running, reporting decreasing number of 
upgrades needed, as expected. I don't know what would happen if I 
allowed the second one to proceed---would they mess up the package 
database? would two upgrades collide writing to the same packaged files?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.fedoraproject.org/pipermail/devel/attachments/20150716/f2573ba0/attachment.html>


More information about the devel mailing list