Fedora Docker Images containing fedora-updates-testing packages

Jon Miller jonebird at gmail.com
Wed Jul 22 22:19:41 UTC 2015


Wanted to point out an issue with the official Fedora Docker container image
for the fedora:20 image. While testing an internally developed package, I ran
into a package dependency problem with the installed openssl-libs package
which appears to have been installed from 

[root at fedora-20 ~]# yum install /usr/bin/authconfig
Error: Package: 1:openssl-1.0.1e-42.fc20.x86_64 (updates)
       Requires: openssl-libs(x86-64) = 1:1.0.1e-42.fc20
       Installed: 1:openssl-libs-1.0.1e-45.fc20.x86_64 (@fedora-updates-testing/$releasever)
            openssl-libs(x86-64) = 1:1.0.1e-45.fc20
       Available: 1:openssl-libs-1.0.1e-30.fc20.x86_64 (fedora)
            openssl-libs(x86-64) = 1:1.0.1e-30.fc20
       Available: 1:openssl-libs-1.0.1e-42.fc20.x86_64 (updates)
            openssl-libs(x86-64) = 1:1.0.1e-42.fc20
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

You can reproduce easily enough by pulling the latest available "fedora:20"
image from Docker and trying to install the authconfig-gtk package.

I tried with the fedora:21 container and it does not have the same
problem. Would be nice, however, if someone could help push an update. 

Jon Miller

More information about the devel mailing list