[ACTION REQUIRED] FTBFS Packages in rawhide (2015-07-27)

Zbigniew Jędrzejewski-Szmek zbyszek at in.waw.pl
Mon Jul 27 14:22:36 UTC 2015


On Mon, Jul 27, 2015 at 10:17:42AM -0400, Matthew Miller wrote:
> On Mon, Jul 27, 2015 at 01:00:26PM +0000, Zbigniew Jędrzejewski-Szmek wrote:
> > A bunch of packages depend on /usr/bin/execstack, provide by prelink.
> > If prelink goes away, they'll be ftbfs immediately. What is
> > the plan here? Can we move execstack somewhere else, or is
> > there a replacement tool?
> 
> What are those? `dnf repoquery --whatrequires /usr/bin/execstack` gives 
>  me nothing. Also I've lived for years without the prelink packaged
> installed and never noticed anything that pulled it in....
Those are build time requirements. Approximately first two pages
in the e-mail I was replying to ;)

Depending on: prelink (24), status change: 2015-07-25 (0 weeks ago)
	aide (maintained by: mildew)
		aide-0.15.1-10.fc23.src requires prelink = 0.5.0-1.fc20

	anyterm (maintained by: abo)
		anyterm-1.1.29-27.fc23.src requires prelink = 0.5.0-1.fc20

	elpa (maintained by: rathann)
		elpa-2015.02.002-5.fc23.src requires prelink = 0.5.0-1.fc20

	gnu-smalltalk (maintained by: s4504kr, laxathom)
		gnu-smalltalk-3.2.5-9.fc23.src requires prelink = 0.5.0-1.fc20

	gromacs (maintained by: rathann, deji)
		gromacs-5.0.5-3.fc23.src requires prelink = 0.5.0-1.fc20

	hugs98 (maintained by: petersen, haskell-sig)
		hugs98-2006.09-22.fc23.src requires prelink = 0.5.0-1.fc20

	lightning (maintained by: s4504kr, laxathom, pcpa)
		lightning-2.1.0-3.fc23.src requires prelink = 0.5.0-1.fc20

	openblas (maintained by: jussilehtola)
		openblas-0.2.14-3.fc23.src requires prelink = 0.5.0-1.fc20

	pypy (maintained by: mstuchli, tomspur)
		pypy-2.5.0-1.fc23.src requires /usr/bin/execstack

	pypy3 (maintained by: churchyard, group::python-sig, mstuchli)
		pypy3-2.4.0-2.fc23.src requires /usr/bin/execstack

	skychart (maintained by: mattia, mmahut)
		skychart-3.10-6.fc23.src requires prelink = 0.5.0-1.fc20

	transgui (maintained by: kumarpraveen)
		transgui-5.0.1-4.fc23.src requires prelink = 0.5.0-1.fc20

	wine (maintained by: awjb, besser82, mooninite, stefanlsd, yayan8)
		wine-1.7.47-1.fc23.src requires prelink = 0.5.0-1.fc20

	zfs-fuse (maintained by: limb)
		zfs-fuse-0.7.0-21.fc23.src requires prelink = 0.5.0-1.fc20

Zbyszek


More information about the devel mailing list