Boost updated to 1.58.0 in rawhide and f23

Adam Williamson adamwill at fedoraproject.org
Wed Jul 29 05:09:23 UTC 2015


On Fri, 2015-07-24 at 19:26 +0100, Jonathan Wakely wrote:
> >> fityk
> 
> Not Boost related:
> 
> app.cpp:12:2: error: #error "Not everything is working with wxGTK3.  
> Use default wxGTK instead, " "based on GTK+2. If you want to test it, 
> just remove this #error."

So this one does exactly what it says on the tin, basically. nonamedotc
changed fityk to build against wxGTK 3 when bumping it to 1.2.9. In
1.3.0 this warning/error was added upstream:

https://github.com/wojdyr/fityk/commit/365cc0f8748d36788f46a81461c717d8
27363e89

to me that strongly suggests we should revert and build fityk against
wxGTK 2, but I didn't want to just go ahead and do that, I thought it'd
be best to see what nonamedotc wants to do. Mukundan, can you please
decide whether you want to:

i) patch out the #error and keep building against wxGTK 3 against
upstream's advice
ii) revert to building against wxGTK 2

and then make the necessary changes and submit builds for the f23-boost
and f24-boost targets (as explained in the first post in this thread),
please? Thanks!
-- 
Adam Williamson
Fedora QA Community Monkey
IRC: adamw | Twitter: AdamW_Fedora | XMPP: adamw AT happyassassin . net
http://www.happyassassin.net



More information about the devel mailing list