[HEADS UP] rpm-4.12.90 in rawhide

Michael Schroeder mls at suse.de
Wed Jul 29 11:00:00 UTC 2015


On Wed, Jul 29, 2015 at 11:08:52AM +0200, Mikolaj Izdebski wrote:
> I think that C-style operators (&, &&) are better than verbose
> COBOL-style ones because they are consistent with relation operators (>,
> >= and so on) already used by rpm. Secondly, they don't introduce
> conflict with existing meaning - "Requires: foo AND bar" is valid syntax
> in rpm <= 4.12, equivalent to requiring three packages separately.

Actually it's "Requires: (foo AND bar)". We currently insist on the
parens to be 100% backwards compatible. It also has the advantage
that the parser knows when the dependency ends and the next one
starts.

Cheers,
  Michael.

-- 
Michael Schroeder                                   mls at suse.de
SUSE LINUX GmbH,           GF Jeff Hawn, HRB 16746 AG Nuernberg
main(_){while(_=~getchar())putchar(~_-1/(~(_|32)/13*2-11)*13);}


More information about the devel mailing list