Strange missing dependencies for claws-mail-plugins-geolocation

Orion Poplawski orion at cora.nwra.com
Thu Oct 1 15:40:49 UTC 2015


On 10/01/2015 09:19 AM, Luigi Votta wrote:
> Hello I'm tring to build claws-mail 3.13.0 with its plugins.
> After running 
> ./configure 
> 
> I've that the geolocation plugin (the only one), will not
> build, cause missing dependencies.
> 
> It claims for 
> champlain-gtk-0.8
> (and perhaps clutter-gtk-0.10 too).
> 
> But they are already installed:
> libchamplain-gtk-0.12.10-1.fc22.i686
> (clutter-gtk-1.6.2-1.fc22.i686)
> 

You are going to need libchamplain-gtk-devel, clutter-gtk-devel

> In the configure.log:
> configure:22045: $PKG_CONFIG --exists --print-errors "champlain-gtk-0.8
>> 0.8.0"
> Package champlain-gtk-0.8 was not found in the pkg-config search path.
> Perhaps you should add the directory containing `champlain-gtk-0.8.pc'
> to the PKG_CONFIG_PATH environment variable
> No package 'champlain-gtk-0.8' found
> 
> Package clutter-gtk-0.10 was not found in the pkg-config search path.
> Perhaps you should add the directory containing `clutter-gtk-0.10.pc'
> to the PKG_CONFIG_PATH environment variable
> No package 'clutter-gtk-0.10' found

You may find even after installing the -devel packages that you don't have the
required versions.


-- 
Orion Poplawski
Technical Manager                     303-415-9701 x222
NWRA, Boulder/CoRA Office             FAX: 303-415-9702
3380 Mitchell Lane                       orion at nwra.com
Boulder, CO 80301                   http://www.nwra.com


More information about the devel mailing list