Removing packages that have broken dependencies in F23 tree

Peter Robinson pbrobinson at gmail.com
Sun Oct 4 05:51:28 UTC 2015


On Sun, Oct 4, 2015 at 4:43 AM, Jerry James <loganjerry at gmail.com> wrote:
> On Thu, Sep 24, 2015 at 8:34 AM, Kalev Lember <kalevlember at gmail.com> wrote:
>> polymake                jjames, rmattes
>
> At long last I have been able to fix this.  The polymake maintainers,
> based on their experience with some unspecified Linux distributions,
> not including Fedora but including Ubuntu, assumed that all 32-bit
> perl builds include 64-bit native integers.  However, Fedora's perl is
> configured so that 32-bit perl has only 32-bit native integers.  The
> polymake maintainers expressed great surprise that Fedora is so
> backward that we haven't heard about 64-bit native integers in 32-bit
> perl yet.  Nonetheless, once the problem was identified, they helped
> me fix it and promised to add a test for this problem to their test
> suite to prevent its reappearance.

Might be worth filing a bug to track/document why we don't have the
64bit ints on 32 bit perl.


More information about the devel mailing list