BuildRequires: pythonN-devel unnecessary

Dominik 'Rathann' Mierzejewski dominik at greysector.net
Thu Oct 29 11:34:21 UTC 2015


On Thursday, 29 October 2015 at 01:31, Christopher Meng wrote:
> On Thu, Oct 29, 2015 at 3:16 AM, Tom Hughes <tom at compton.nu> wrote:
> >
> > On 28/10/15 19:12, Mike Bonnet wrote:
> >>
> >> https://fedoraproject.org/wiki/Packaging:Python#BuildRequires
> >>
> >> This is *not* required for pure Python packages, only for packages
> >> compiling native extensions:
> >
> >
> > Are you sure? Don't you need them for the RPM macros they contain?
> 
> Not my first time hitting on missing macros just because lack of
> pythonN-devel, but if you just extract them from pythonN-devel to package
> similar to these packages below, I reckon that it should be acceptable:
> 
> ---
> ghc-srpm-macros
> gnat-srpm-macros
> go-srpm-macros
> ocaml-srpm-macros
> perl-srpm-macros
> ---

How about naming them:
rpm-build-ghc
rpm-build-gnat
rpm-build-go
rpm-build-ocaml
rpm-build-perl
rpm-build-python
and so on?

Also, add
Supplements: rpm-build
to each of them.

Regards,
Dominik
-- 
Fedora http://fedoraproject.org/wiki/User:Rathann
RPMFusion http://rpmfusion.org
"Faith manages."
        -- Delenn to Lennier in Babylon 5:"Confessions and Lamentations"


More information about the devel mailing list