<div dir="ltr"><div class="gmail_extra"><div class="gmail_quote">2014-04-24 17:22 GMT+02:00 Jerry James <span dir="ltr">&lt;<a href="mailto:loganjerry@gmail.com" target="_blank">loganjerry@gmail.com</a>&gt;</span>:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<div class="">On Thu, Apr 24, 2014 at 8:50 AM, Kevin Fenzi &lt;<a href="mailto:kevin@scrye.com">kevin@scrye.com</a>&gt; wrote:<br>
&gt; Yeah, which makes technical sense... but the concern is packagers who<br>
&gt; aren&#39;t paying attention rebuild for some other reason and are not on v6<br>
&gt; when it&#39;s a licensing problem. ;(<br>
<br>
</div>I need some advice on how to handle this for XEmacs, which is a GPLv3+<br>
package.  It provides some optional database functionality, but the<br>
underlying database can be any of libdb, gdbm, or postgresql.  When I<br>
first turned this on for Fedora, in response to a request in bz<br>
581614, I chose libdb for reasons that I no longer remember.  So now I<br>
need to choose between:<br>
- libdb (going to AGPLv3+)<br>
- gdbm (GPLv3+)<br>
- postgresql (PostgreSQL, essentially MIT)<br></blockquote><div>You&#39;ll have the option of moving to libdb5 , without a license change or need to convert data.  That should be easiest, at least in the medium term while libdb5 is actively maintained.<br>
</div><div>    Mirek<br></div></div><br></div></div>