aYUMda: instalar Mysql en FC5

Gonzalo Aguilera - Diputación de Ávila gaguilera at diputacionavila.es
Tue Mar 22 09:34:38 UTC 2011


¡Hola!

Yo no mezclaría paquetes de distintas versiones. Puedes cambiar el repositorio de updates  a 

baseurl=ftp://ftp.pbone.net/mirror/archive.fedoraproject.org/fedora/linux/core/updates/5/x86_64/

y así utilizar paquetes de la distribución que tienes instalada.
  ----- Original Message ----- 
  From: Ignacio Marín Hernández 
  To: es-users at lists.fedoraproject.org 
  Sent: Tuesday, March 22, 2011 10:15 AM
  Subject: aYUMda: instalar Mysql en FC5


  Buenos días a todos! Soy un programador Web que también está ejerciendo de administrador de Sistemas, y estoy algo perdido. 
  Estoy intentando instalar un mysql en un FedoraCore5 (x86_64). Ya sé que vamos por Fedora 15, pero me da pánico actualizar el sevidor Web por ahora.

  El primer problema es que tenía desactualizados los repositorios, que apuntaban a la dirección http://download.fedora.redhat.com/, y los tuve que actualizar todos a http://archive.fedoraproject.org/

  Hasta ahí bien, excepto que para el respositorio de UPDATES donde ya no están subidos los paquetes para FC5 y tube que poner a mano la dirección para el FC7. Es decir, en el archivo fedora-updates.repo comenté la siguiente linea:
  #baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/updates/$releasever/$basearch/
  y la sustituí por:
  baseurl=http://archive.fedoraproject.org/pub/archive/fedora/linux/updates/7/x86_64/

  Con esto ya me funcionaba bien los YUM, pero al hacer yum -y install mysql-server.x86_64 me da el siguiente error de dependencias:
  Error: Missing Dependency: php = 5.1.6-1.6 is needed by package php-pdo
  Error: Missing Dependency: php = 5.1.6-1.6 is needed by package php-mbstring
  Error: Missing Dependency: php = 5.1.6-1.6 is needed by package php-xml
  Error: Missing Dependency: libdb-4.5.so()(64bit) is needed by package apr-util

  Y aquí es donde viene mi duda. Mi servidor Web ya tiene instalado un postgressql y hay muchas webs funcionando sobre él. ¿Hay alguna posibilidad que al instalar los paquetes que me piden, haya algún tipo de incompatibilidades entre el Postgresl y el PHP ya instalado? Lo pregunto porque sería catastrófico que dejasen de funcionar las Webs! Mi miedo viene porque no sé si al instalar paquetes del FC7 en un FC5 me va a dejar de funcionar el PHP y PostGresql. Los paquetes que tengo instalados actualmente son:
  apr-util-1.2.7-1.1 
  php-mbstring-5.1.6-1.6
  php-xml-5.1.6-1.6
  php-pdo-5.1.6-1.6

  Y por ejemplo al hacer un yum search php-pdo me da los siguientes paquetes:

  php-pdo.x86_64 5.1.2-5 core
  php-pdo.x86_64 5.2.6-2.fc7 updates
  php-pdo.x86_64 5.1.6-1.6 installed

  Me gustaría estar completamente seguro que no va a pasar nada al instalar el paquete de Fedora7 php-pdo.x86_64 5.2.6-2.fc7 en mi Fedora 5

  Muchas gracias de antemano 


------------------------------------------------------------------------------


  --
  es-users mailing list
  es-users at lists.fedoraproject.org
  To unsubscribe: 
  https://admin.fedoraproject.org/mailman/listinfo/es-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.fedoraproject.org/pipermail/es-users/attachments/20110322/45615174/attachment.html 


More information about the es-users mailing list