woes with the upgrade to qt 4.5

José Matos jamatos at fc.up.pt
Fri Feb 20 16:48:21 UTC 2009


Here follows a summary after several hours of struggle. :-)

After upgrading to qt-4.5 the problem happens between kde4 and qt4 
applications where it looks like the fonts are shredded. To see an example of 
what I mean see my desktop http://www.fep.up.pt/docentes/jamatos/desktop1.png 
with this nice artifacts. :-)

Funnily enough I don't get this problem with non-qt4 applications on kde and 
if I change to gnome all the applications work as expected (including qt4 
based apps).

I have moved away .kde and .kderc but the problem remains. I have tried the 
same with $HOME/.config/Trolltech... and no joy as well. After entering the 
first time the same problem with fonts would appear immediately.

I tried to use my wife's account that was empty and the problems does not show 
there so I suspect that there is some configuration file somewhere that leads 
to garbled fonts.

Since I was running out of time and without further ideas I have downgraded to 
qt-4.4.3 where all works as usual.

Regards,
-- 
José Abílio



More information about the kde mailing list