hp-setup doesn't run

Timothy Murphy gayleard at eircom.net
Thu Jul 30 10:04:31 UTC 2009


Anne Wilson wrote:

>> >> (In my case, when I run it [system-config-printer],
>> >> I am not asked for the root password,
>> >> and most of the possible actions are greyed-out.)

> That's normal when it needs SU mode, of course.  Yes, it would be useful
> to either ask for the password or tell you what's wrong.

But as I said, the result is actually the same
if I run system-config-printer as root.
I am told I am not authorized to change the Media Size (from letter to A4).
In fact it is worse if I run as root,
since I cannot leave the program - I have to kill it from another console.

> Doesn't launching hp-setup from a root terminal work?

As far as I can see, hp-setup only allows me to install a second printer,
not to modify an existing one.

I should perhaps have made clear that the CUPS web interface
does allow me to change the media size;
my remarks were only addressed at system-config-printer.

Incidentally, I was trying to discover where the page size (letter or A4)
is stored on the computer.
I couldn't find any mention of it in /etc/cups, /var/spool/cups 
or /var/run/cups .



-- 
Timothy Murphy  
e-mail: gayleard /at/ eircom.net
tel: +353-86-2336090, +353-1-2842366
s-mail: School of Mathematics, Trinity College, Dublin 2, Ireland





More information about the kde mailing list