Strange usb-mount behaviour - SOLVED

Michael J Gruber michaeljgruber+gmane at
Mon May 18 12:16:36 UTC 2009

Anne Wilson venit, vidit, dixit 14.05.2009 16:22:
> On Thursday 14 May 2009 14:30:31 Michael J Gruber wrote:
>> Well, some of us still use the command-line... 
> Oops - sorry - didn't think of it in that context.
>> but would like KDE to do
>> the mount, either automatically, or by using the mount helper. But it
>> doesn't even have an entry for "mount", does it?
> Sort of like kwikdisk used to?
>> Also, I don't seem to be able to specify mount options. If the volume is
>> in fstab then the mount helper refuses to mount them/open them in
>> Dolphin, no matter whether the mount points exists or not. The defaults
>> have changed recently (F10 updates), so that's a bit of a nuisance.
> I don't understand what you are saying here.  You have an entry in fstab for a 
> pendrive?  The device notifier recognises the device but won't mount it?
> My F10 is on a netbook, and I don't have any such entry in my fstab.  Give me 
> the fullest details you can and I'll try to recreate the problem.  I need to 
> fully understand it before I can ask the right questions to get an answer for 
> you.

This is on a fully updated F10. A few weeks ago, the underlying system
for usb automounts changed (from or to hal or whatever). As a
consequence, the defaults mount options for vfat changed from
"shortname=lower" to something else (upper or mixed), which has the
effect that, e.g., file names of images on memory cards appear in upper
case now. This is bad when you rsync increasingly filling cards over to
your disk, of course. The new system does not have any means to provide
default options. So, according to advice from another list, I put

LABEL=EOS_DIGITAL       /media/EOS_DIGITAL      auto
noauto,rw,nosuid,nodev,uhelper=hal,owner,utf8,shortname=lower   0 0

in fstab which is the line which the usb-mounter adds, but with changed
shortname. I tried with and without existing mount-point, and see the
same effect:

The device notifier lists that volume.
Opening it with dolphin (through the notifier) makes dolphin open a path
underneath my $HOME, but no mount is happening.

I can mount from the command line (if the mount-point exists), so the
line above is OK.


More information about the kde mailing list