GCC 4.4 rebuild results

Richard W.M. Jones rjones at redhat.com
Mon Feb 23 16:12:30 UTC 2009

On Fri, Feb 20, 2009 at 06:41:46PM +0000, Richard W.M. Jones wrote:
>  - mingw32-qt-win (4.4.3)
>    version we were building, this fails.  Solution requires upgrading
>    the mingw32-qt-win package and adding a hard BuildRequires on
>    qt-devel = %{version}.

While I remember, the above didn't actually work.  If I have:

  Version: 4.5.0
  BuildRequires: qt-devel = %{version}

then it won't find qt-devel in Rawhide which is 4.5.0-<<some release>>

So we still have an unversioned BuildRequires (and Requires) in that

Anyone got any ideas about this?  My best bet was this which is pretty

  BuildRequires: qt-devel >= 4.5.0
  BuildRequires: qt-devel <  4.5.1


Richard Jones, Emerging Technologies, Red Hat  http://et.redhat.com/~rjones
Read my OCaml programming blog: http://camltastic.blogspot.com/
Fedora now supports 68 OCaml packages (the OPEN alternative to F#)

More information about the mingw mailing list