[Bug 490888] New: All fonts are monospace after upgrade to fontconfig-2.6.99.behdad-3

bugzilla at redhat.com bugzilla at redhat.com
Wed Mar 18 13:11:28 UTC 2009

Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug.

Summary: All fonts are monospace after upgrade to fontconfig-2.6.99.behdad-3


           Summary: All fonts are monospace after upgrade to
           Product: Fedora
           Version: rawhide
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: medium
          Priority: medium
         Component: fontconfig
        AssignedTo: besfahbo at redhat.com
        ReportedBy: mschmidt at redhat.com
         QAContact: extras-qa at fedoraproject.org
                CC: besfahbo at redhat.com, fedora-fonts-bugs-list at redhat.com
    Classification: Fedora
    Target Release: ---

Description of problem:
Today I did 'yum update' on my Rawhide KVM guest. About 20 packages were
updated, among them was fontconfig. After reboot to get the new kernel, all
fonts in GDM were monospaced and without antialiasing. After logging in into
GNOME everything was monospaced and no AA too (menus, window titles,
gnome-terminal, ...). I thought I had lost my Preferences -> Appearance ->
Fonts settings, so I went there to check, but all fonts appeared the same.

The problem was fixed it by running 'fc-cache -r' and logging out and back in.

Version-Release number of selected component (if applicable):
The upgrade was from:

How reproducible:
Not sure. I haven't tried downgrading and repeating the upgrade yet.

Steps to Reproduce:
1. Update fontconfig 
2. Reboot (although relogin would probably be sufficient)

Actual results:
All fonts are monospace and without antialiasing.

Expected results:
Font should look as they did before the upgrade.

Additional info:
I suspect the bug is in fontconfig's postinstall script where it does:
rm -f /var/cache/fontconfig/????????????????????????????????.cache-2
But at least on my system the number of question marks does not correspond to
the actual filename lengths of the files in that directory. E.g.

(the "-x86-64" is not accounted for)

Configure bugmail: https://bugzilla.redhat.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

More information about the fonts-bugs mailing list