[Bug 497646] Upgrade path is broken

bugzilla at redhat.com bugzilla at redhat.com
Wed May 13 07:39:50 UTC 2009


Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug.


https://bugzilla.redhat.com/show_bug.cgi?id=497646





--- Comment #16 from Nicolas Mailhot <nicolas.mailhot at laposte.net>  2009-05-13 03:39:49 EDT ---
(In reply to comment #13)
> (In reply to comment #12)

> > I think we need just:
> > 
> > Obsoletes:    liberation-fonts-sans < 1.04.93-4
> > 
> > and similarly for mono and serif.  
> 
> No, you don't need that since it's already automatically done by rpm. You can
> remove those lines altogether.  

Read again.

As for your patch, I'm strongly against it.
1. you're introducing a common provides while making sure packagers had to take
into account the different fonts was an explicit packaging goal
2. as far as I understand, you're relying on undocumented yum behaviour the yum
developpers never committed to

If you want to change the way we package fonts, go the full public consultation
=> FPC review => FESCO review => months of QA like was done for F11

-- 
Configure bugmail: https://bugzilla.redhat.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.




More information about the fonts-bugs mailing list